首页 > 云开发 > Linux > 正文

后台-系统设置-扩展变量-手机广告位-内容正文顶部

manjaro 深度学习编程环境搭建

Linux

常用深度学习编程框架安装
pacman -S cuda cudnn
# 安装 pytorch
pacman -S python-pytorch-cuda
# 安装 tensorflow
pacman -S python-tensorflow-cuda
# 安装 pycharm
yay -S pycharm-community-eap
# 安装 jupyter notebook
pacman -S jupyter-notebook
tensorflow 小bug(与pytorch同时安装导致) bug描述

当使用import tensorflow as tf时,如下报错

RequestsDependencyWarning: urllib3 (1.25.2) or chardet (3.0.4) doesn't match a supported version!
解决办法
# 更新requests.--user参数目的在于安装到家目录,防止污染公共环境
pip install --user --upgrade requests
参考

bug

解决办法

jupyter-notebook 设置默认打开浏览器

jupyter notebook --generate-config

编辑文件: ~/.jupyter/jupyter_notebook_config.py

将该行:# c.NotebookApp.browser = ''
修改为c.NotebookApp.browser = '/usr/bin/web_browser' %s,其中web_browser为浏览器可执行程序名称,一般在/usr/bin/目录下。

参考

mariadb数据库安装

pacman -S mariadb

mysql_install_db --user=mysql --basedir=/usr --datadir=/var/lib/mysql

开启数据库服务 systemctl start mariadb

将数据库服务设置为开机启动 systemctl enable mariadb

基本配置

方式1: sudo mariadb_secure_installation 通过该命令进行基本配置即可

方式2: 设置密码mysqladmin -u root password 'newpassword'

参考

https://wiki.archlinux.org/in...

https://www.unixmen.com/insta...

neo4j manjaro 安装

参考

首先,要查看manjaro使用的openjdk的版本archlinux-java status,可以看到java版本为12,8

;通过查看neo4j的系统要求可知,java版本为8,我们可以通过archlinux-java修改全局java版本,也可以使用编写脚本的方式设置运行时的java版本,脚本如下所示参考

$ archlinux-java status
Available Java environments:
  java-12-openjdk (default)
  java-8-openjdk

neo4j启动脚本

#!/bin/sh
export JAVA_HOME="/usr/lib/jvm/java-8-openjdk"
export PATH=$JAVA_HOME/bin:$PATH
exec /opt/neo4j-community-3.5.8/bin/neo4j console 

neo4j的安装,虽然archlinux仓库中有打包好的软件包,但是自己使用过程中,出现有bug,所以这里推荐使用,手动从官网下载相应版本.解压之后,即可使用.

文章来源:segmentfault,作者:lifan。如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件至:william.shi#ucloud.cn(邮箱中#请改为@)进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容。
后台-系统设置-扩展变量-手机广告位-内容正文底部

推荐文章

热门标签

    热门文章 最新文章 文章云

站内导航

全站搜索